What you need to install Joomla

In order to install joomla 2.5+ you need the following requirements in your hosting environment:

  • PHP 5.2 or Higher : php is scripting language which joomla uses.
  • Mysql 5.0.4 or Higher: Mysql is the database where joomla stores all its content
  • Apache 1.3 or higher: (Apache 2.0.x) is recommended! Apache is a web server that process your php language and pulls the database from Mysql and shows them in our webpage.
  • XML and Zlib support: make sure hosting environment supports these functionality.

To find more detailed installation you can check on the following links:

Joomla Technical Requirements